Performance Degradation

Minor incident Platform Chat Agents Apps Dashboard
2026-07-06 15:55 PDT · 8 minutes

Updates

Resolved

We’ve identified the root cause of this issue as a downstream outage and are escalating to a major incident.

July 6, 2026 · 16:04 PDT
Investigating

We’re seeing a performance degradation platform wide.

July 6, 2026 · 15:55 PDT

← Back